Q. 自動更新機能がうまく作動しません
A. 自動更新機能がうまく作動しない場合、以下のいずれかに当てはまっている可能性が高いです。
1.自動更新を「ON」にする前に、既にトリガー対象日を迎えている(初回ログインが完了している)
2.自動更新機能を「ON」にした後、過去に遡って履歴を作成している
3.利用状況ステータスがトリガー対象外である
上記に当てはまっている場合、自動更新機能の対象外となり、作動しません。
本記事では原因ごとの確認方法や解決方法をご説明します。
目次
1.自動更新を「ON」にする前に、既にトリガー対象日を迎えている(初回ログインが完了している)
2.自動更新機能を「ON」にした後、過去に遡って履歴を作成している
3.利用状況ステータスがトリガー対象外である
補足:自動更新機能ごとの作動しない原因について
・【アカウントを「利用中」に切り替える】で、一部社員が変更されない
・【退職日の翌日にアカウントを「利用停止」に切り替える】が作動しない
・【業務メールアドレスを認証メールアドレスに設定する】が作動しない
・【認証方法を「SSO」に切り替える】が作動しない
詳細
1.自動更新を「ON」にする前に、既にトリガー対象日を迎えている(初回ログインが完了している)
自動更新機能は、「ON」に設定後に、トリガー対象日を迎えたアカウントが作動対象となります。
そのため、自動更新機能を「ON」に設定する前にトリガー対象日を迎えたアカウントについては、該当アカウントに対し自動更新機能は作動しません。
また、同様に、初回ログインをトリガーとした機能は、自動更新機能を「ON」に設定する前に初回ログインを完了している場合も対象外となります。
<例>
【退職日の翌日にアカウントを「利用停止」に切り替える】の場合
2025/4/1に自動更新機能を「ON」に設定した場合、業務情報 > 入社・退職 >「退職日」が2025/3/31以前で登録されているアカウントは対象外のため、「利用停止」に切り替わらない
2.自動更新機能を「ON」にした後、過去に遡って履歴を作成している
自動更新機能は、「ON」に設定後に、トリガー対象日を迎えたアカウントが動作対象となります。
そのため、トリガー対象日を過ぎてから、 過去に遡って履歴を作成した場合は、該当アカウントは対象外となり、自動更新機能は作動しません。
<例>
【退職日の翌日にアカウントを「利用停止」に切り替える】の場合
2025/4/1に自動更新機能を「ON」に設定した後、既に退職済みの社員のアカウントに対し、業務情報 > 入社・退職 >「退職日」を2025/3/31で登録した場合、該当アカウントは対象外となり、「利用停止」に切り替わらない
自動更新機能を「ON」にしたタイミングが、トリガー対象日当日である場合
当日に動作する機能については、トリガー対象日当日の0時以降順次に作動する仕組みであるため、当日に「ON」にした場合は対象外となり、作動しません。
<トリガー対象日当日に動作する機能>
・アカウントを「利用中」に切り替える
HRMOSに招待された社員の入社日に変更(全社員)
HRMOSに招待された社員が入社日を迎えたタイミング(役員、正社員、契約社員のみ)
・認証メールアドレスを「業務メールアドレス」に切り替える
・認証方法を「SSO」に切り替えるただし、トリガー対象日の翌日に作動する機能は、トリガー対象日当日に「ON」にした場合も対象となり、作動します。
<トリガー対象日の翌日に作動する機能>
・退職日の翌日にアカウントを「利用停止」に切り替える
3.利用状況ステータスがトリガー対象外である
自動更新機能は、機能によって作動対象となる利用状況ステータスが異なります。
対象となる利用状況ステータス以外のアカウントに関しては、自動更新機能は作動しません。
| 機能 | 作動対象となる利用状況ステータス |
| アカウントを「利用中」に切り替える | 「利用制限」 |
| 退職日の翌日にアカウントを「利用停止」に切り替える | 「招待済み」「利用制限」「利用中」 |
| 認証メールアドレスを「業務メールアドレス」に切り替える | 「招待済み」「利用制限」「利用中」 |
| 認証方法を「SSO」に切り替える | 「招待済み」「利用制限」「利用中」 |
補足:自動更新機能ごとの作動しない原因について
上記でご説明した要因以外にも、各自動更新機能ごとに個別に対象外となる要因があります。
以下にて、それぞれの原因と、解決方法をご案内します。
※既に既にトリガーの動作タイミングを過ぎている、対象外のアカウントに対しては、手動での利用停止をお願いします。利用停止にする手順は<こちら>をご確認ください。
【アカウントを「利用中」に切り替える】で、一部社員が変更されない
■原因
【HRMOSに招待された社員が入社日を迎えたタイミング(役員、正社員、契約社員のみ)】を「ON」にしている
■解決方法
【HRMOSに招待された社員の入社日に変更(全社員)】を「ON」にする
【退職日の翌日にアカウントを「利用停止」に切り替える】が作動しない
■原因
業務情報 > 基本情報 > 在籍情報のステータスが「退職済」になっていない
■解決方法
業務情報 > 入社・退職 > 退職日を入力し、業務情報 > 基本情報 > 在籍情報のステータスを「退職済」にする
【業務メールアドレスを認証メールアドレスに設定する】が作動しない
■原因
業務情報 > 基本情報 > 業務メールアドレスが未登録になっている
■解決方法
業務情報 > 基本情報 > 業務メールアドレスを、業務情報 > 入社・退職 > 入社日までに登録する
【認証方法を「SSO」に切り替える】が作動しない
■原因
SSOの設定が完了していない
■解決方法
SSOの設定を、業務情報 > 入社・退職 > 入社日までに完了する